PDM_K_REINDEX fails with Critical Error

Document ID : KB000108066
Last Modified Date : 30/07/2018
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Issue:
PDM_K_REINDEX command fails with a 'Critical Error' within the EBR_REINDEX log.  

"The program was not successful due to a critical error. Please see the log files for further details."

The SDM STDLOG shows the following errors:

SDMSERVER sqlagt:CREATE_IND 9716 ERROR sql_common.c 302 CREATE INDEX returned 11  [Microsoft OLE DB Provider for SQL Server] [ SQL Code=0 SQL State=08S01] Connection failure

SDMSERVER sqlagt:CREATE_IND 9716 ERROR sql_common.c 303 CREATE UNIQUE INDEX "ebr_fulltext_adm_x0" ON "ebr_fulltext_adm" ( "id" ASC ) 

SDMSERVER sqlagt:CREATE_IND 9716 ERROR sqlsrvr.c 651 Execution failed. MISC_DB_ERROR

SDMSERVER bpvirtdb_srvr 3176 ERROR vdbsql.c 5791 CREATE INDEX agent got database error 15
 
Environment:
CA Service Desk Manager 14.1 and 17.x
All Supported Operating Systems
Cause:
Based on the error messages, there is a problem with the SQL agent (sqlagt:CREATE_IND) connection to the DBMS server that has the MDB database. 
Resolution:
Restart the SDM service to reinitialize the SQL agent (sqlagt :CREATE_IND ) connection to the DBMS server that has the MDB database. 
Additional Information:
https://docops.ca.com/ca-service-management/17-1/en/reference/ca-service-desk-manager-reference-commands/technical-reference/ca-sdm-pdm-database-commands#CASDMPDMDatabaseCommands-pdm_k_reindex--KnowledgeRe-IndexUtility