Knowledge Approval Process not allowing rejection

Document ID : KB000121523
Last Modified Date : 26/11/2018
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Issue:
Following message is generated when attempting to reject a knowledge doc:

"servicedesk.chq.ei says Task selection is required."

However there are no tasks to select from.
Environment:
SDM 17.1
Cause:
This is because the previous tasks are not available for the user/role.

When given Modify function access the reject completes, the previous tasks do not show, but the reject completes.
Resolution:
Looking at network traces check for a call to :

http://XXX:8080/CAisd/pdmweb.exe?SID=873026306+FID=7268+KEEP.DOC_ID=400301+OP=KT_ACTION_REJECT

That receives as a response error:

AHD04483:Security Access Violation

AHD04482:Security setting prevents this operation. See Administrator for details.


Copy the op_kt_admin.cfg file from Install_Dir\bopcfg\www to Install_Dir\site\mods\www and change the field below
From :
KT_ACTION_REJECT kt_admin_main MODIFY

To:
KT_ACTION_REJECT kt_admin_main VIEW

Recycle SDM for this change to take effect.