Key generation is off. Please enable the Key generation java.net.UnknownHostException: unknown error

Document ID : KB000006696
Last Modified Date : 05/10/2018
Show Technical Document Details
Issue:

The Customer is not able to connect to the Jasper Report Server from the CA Identity Manager user interface.

 

In CA Identity Manager, select menu System, Reporting,  Report Server Connection.

In the CA Identity Manager log file (/opt/CA/wildfly-idm/standalone/log/server.log), the following error message appears:

 

Key generation is off. Please enable the Key generation java.net.UnknownHostException: XXXXXXX: unknown error

 

Where XXXXXXX is the Jasper Server hostname

 

Environment:
CA Identity Manager 14.0.x
Cause:

The root cause is that Windows Firewall is ON (enabled) for the Jasper Server machine.

Resolution:

Turn off the Windows Firewall. The server is now able to ping Jasper Server machine from the vApp machine.

In CA Identity Manager, use the IP instead of the hostname in the "Report Server URL" field.

 

JasperConnection.PNG