JWP startup error following upgrade to 12.2

Document ID : KB000103922
Last Modified Date : 03/07/2018
Show Technical Document Details
Issue:
An AWA system has been updated manually from version 12.1 to version 12.2 by a simple copy and paste of the bin folder. 

When trying to startup the JWP with  the following command line:

========================================================================
nohup $UC4_HOME/java/bin/java -Xmx512M -jar $UC4_HOME/server/bin/ucsrvjp.jar -I$UC4_HOME/server/bin/ucsrv.ini &
========================================================================

...the application returns following error message is found in the process log file:

========================================================================
Error message: org.osgi.framework.BundleException: The bundle "com.automic.ara_1.0.0 [21]" could not be resolved. Reason: Missing Constraint: Import-Package: com.autom ic.protocol; version="1.0.0" at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1332) at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1316) at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323) at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:300) at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:292) at com.automic.server.startup.Main.main(Main.java:123) Could you help us on this issue ?
========================================================================


 
Environment:
Problem has been encountered only on Linux systems so far
Cause:
During the update the contained jar-binaries are add to the bin/plugins subfoler, but as some of these compounds do not have have exactly the same name, the obsolete plugins are not overwritten. These obsolete compounds still interfere with One Automaion and can hinder plugin depending processes like the JWP to start.

The list of these obsolete and remaining compounds :

===============================================================================
com.automic.ara.jar 
fragment_201806291420_db_ojdbc8.jar 
javax.servlet.jar 
org.eclipse.equinox.http.servlet.jar 
org.eclipse.equinox.util.jar 
org.eclipse.jetty.continuation.jar 
org.eclipse.jetty.http.jar 
org.eclipse.jetty.io.jar 
org.eclipse.jetty.security.jar 
org.eclipse.jetty.server.jar 
org.eclipse.jetty.servlet.jar 
org.eclipse.jetty.util.jar 
===============================================================================
 
Resolution:
To resolve this issue proceed with a complete cleanup of the ./bin/plugins folder.

Stop Automation Engine
Delete all files in the ./bin/plugins subfolder ot the engine.
Deploy all the version 12.2 plugins compounds again into the bin/plugins folder of the instance.