Jobs stuck in generating

Document ID : KB000121552
Last Modified Date : 27/11/2018
Show Technical Document Details
Issue:
During a period the processing of jobs slows down and job remain in status "Generating".

The following message are found in the same second but in different WP log.

In WP log WPsrv_<SYSTEM>_<date>_xxx_00.txt:

 U00029108 UCUDB: SQL_ERROR    Database handles  DB-HENV: c28ea0  DB-HDBC: c9ecd8
 U00003591 UCUDB - DB error info: OPC: 'OCIStmtExecute' Return code: 'ERROR'
 U00003592 UCUDB - Status: '' Native error: '60' Msg: 'ORA-00060: deadlock detected while waiting for resource'

In WPsrv_<SYSTEM>_<date>_yyy_00.txt:

 U00003524 UCUDB: ===> Time critical DB call!       OPC: 'SLCU' time: '97:922.434.999'
 U00029131 UCUDB - List of bind parameters:
 U00029132 UCUDB: 'RT_AH_Idnr         = <Idnr>'
 U00029132 UCUDB: 'RT_Type            = ACT'
 U00029132 UCUDB: 'RT_AH_Idnr         = <Idnr>'
 U00029132 UCUDB: 'RT_Type            = ACT'
 U00003525 UCUDB: ===> 'SELECT RT_Lnr FROM RT WHERE RT_AH_Idnr = ? AND RT_Type = ? AND RT_Lnr IN (SELECT MAX(RT_Lnr) FROM RT WHERE RT_AH_Idnr = ? and RT_TYPE = ?)'
Cause:
HOSTG resolution log was written in top Workflow which decreased database performance.
Resolution:
With this change the HOSTG resolution log is now written in the job report.
 

Solution:

Update to a fix version listed below or a newer version if available.

 

Fix version:

Component(s): Automation.Engine

Automation.Engine v12.0.7 - Planned Release 2019-01-14
Automation.Engine v12.1.4 - Planned Release 2019-01-28
Automation.Engine v12.2.1 - Available
Automation.Engine v12.3.0 - Planned Release 2019-02-28
Automation.Engine v12.1.3 HF1 - Available