Jobs failing on new Informatica agent

Document ID : KB000009302
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

The Informatica job fails and the following error is seen in the agent logs

Error Code: -109 Error Message: Unable to establish connection with Informatica Server Message Context: IJLMDriver::getConnectionEx(INF_TEST_Domain,inftest_96_repo_Integration_Service,360)

@at com.informatica.powercenter.sdk.lm.JLMException.handleExceptionOrWarning(JLMException.java:545)

@at com.informatica.powercenter.sdk.lm.JLMDriver10.getConnectionEx(JLMDriver10.java:259)

@at cybermation.plugins.informatica.cli.CybInformaticaCLIDriver.getConnection(CybInformaticaCLIDriver.java:444)

@at cybermation.plugins.informatica.cli.CybInformaticaCLIDriver.main(CybInformaticaCLIDriver.java:179)

 

 

Environment:
CA Workload Automation Agent for Informatica 11.3CA WA Agent 11.3
Cause:

The "Unable to establish connection with Informatica Server Message Context" error occurs when an agent is not able to connect to the Informatica or if there are settings issue on the CA WA Agent side.  When installing the agent follow the steps provided in the documentation.

Resolution:

When the Agent is installed, make sure the following steps are completed properly. 

Copy the 'domains.infa' file from Informatica PowerCenter to agent host (if the agent is on a remote host).

Set the "INFA_DOMAINS_FILE" environment variable on the host. 

E.g. If the domains.infa is in /opt/agent/domans.infa then set "INFA_DOMAINS_FILE" as this: 

INFA_DOMAINS_FILE=/opt/agent/domans.infa

You may need to logout and log back in for environment variable to be set.

You will also need to set the "INFA_TRUSTSTORE" environment variable.  Copy the "infa_truststore.pem" to the agent host and point the "INFA_TRUSTSTORE" to directory where "infa_truststore.pem" is located. 

E.g. INFA_TRUSTSTORE=/opt/agent/infa_files

Additional Information:

The domains.infa file needs to be exactly same on the agent as it is on the PowerCenter.  If the XML tags are different, then jobs will fail.

It is recommended to copy the file from Informatica to the agent host.  Make sure the following tags match, (your tags may be different):

... xsi:type="common:PCSFVector" objVersion="1.1.19">

<vector xsi:type="domainservice:Portals" objVersion="1.1.19"><domainName>CORP_Dev_Domain</domainName>

<address xsi:type="metadata:NodeRef" objVersion="1.1.19"><host>INFAHOST001</host><port>6005</port></address><tlsEnabled>true</tlsEnabled>

<kerberosEnabled>false</kerberosEnabled></vector></Portals>