Job Status reports contains no data for given parameter

Document ID : KB000003882
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

When running Job Status Reports within WCC under 'Reporting' tab, it produces following error message in the report output pane:

"Job Status Success/Failure Report contains no data for given parameters"

This is also the case for 'Job Run Reports'.

Environment:
Any WCC release in a CA WAAE 11.3.x environment
Cause:

The reason is that Autosys aggregation did not run

Resolution:

To trigger once the statistics computation you need to use one of the following commands on the WAAE server:

 

For WAAE 11.3:      autoaggr -h
For WAAE 11.3.5:    sendevent -E AGGREGATE -l HOURLY

Otherwise check if AggregateStatistics option has been set in the Autosys configuration or in
the Autosys Admin Graphical interface on Windows

AggregateStatistics=1

# Keyword: AggregateStatistics=<value>
#
# Aggregate  CA Workload Automation AE   statistics  into   hourly,
# daily, weekly, and  monthly  tables that other programs will  use
# to generate  reports. The CA Workload Automation AE  SDKs provide
# APIs to retrieve the data generated by the aggregation process.
#
# The valid values are as follows:
#
#    0 = Specifies no aggregation is to be performed.
#
#    1 = Specifies  aggregation  will  be  performed  to update the
#        hourly, daily, weekly and monthly tables.
#
# Notes:
#
# 1. Daily  aggregation  is   performed  at midnight  on  each  new
#    calendar day.
# 2. Weekly aggregation  is performed at midnight on Sunday of each
#    new calendar week.
# 3. Monthly aggregation is performed at midnight on the 1st day of
#    each new calendar month.
#
# Default: 1
#
AggregateStatistics=1
Additional Information: