Job fails to run on Windows with error CAWA_E_20020 Logon failed

Document ID : KB000007076
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Job fails to run on a Windows Agent with the following message reported in the spool:

CAWA_E_20020 Logon failed for ASPEN\SVC_US_PDR_ST due to: Logon failure: unknown user name or bad password. Error code: 1326 

 

Environment:
WA AE 11.3.6 SP4 on Windows
Resolution:

The encountered problem can be related to the machine definition or the job owner credentials needed to be added in autosys_secure.

The recommended solution was to add the following attribute to the machine definition:

opsys : windows

 

Example:

insert_machine: machine-name

type: a

node_name: agent-node-name

opsys: windows

 

The problem maybe resolved by adding opsys: windows attribute to the machine definition.

To list the machine definition you can run the command

 autorep -m <machine_name> -q

If the problem persists confirm that the  job owner is defined in autosys_secure and not locked by operating system. Only for windows agents jobs requires users and passwords are defined in autosys_secure.

To list the job definition

autorep -J <job> -q

To lists all users with passwords from the command line run

autosys_secure -s -host ALL

Additional Information:

You can find autosys_secure command documentation here

https://docops.ca.com/ca-workload-automation-ae/11-4-2/en/reference/ae-commands/manage-security/autosys_secure-command-define-security-settings