Job aborts with the error message "Error=12, There is not enough memory available now"

Document ID : KB000087565
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
ErrorMsg: AwE-9999 Internal error (12/27/16 11:30 PM)
Details: null
java.io.IOException: Cannot run program "sh" (in directory "/APPWORX/8.0/agent/run"): error=12, There is not enough memory available now.

Job Aborts and the following error is displayed in the AgentService log where the Job was launched.
 
ErrorMsg: AwE-9999 Internal error (12/27/16 11:30 PM)
Details: null
java.io.IOException: Cannot run program "sh" (in directory "/APPWORX/8.0/agent/run"): error=12, There is not enough memory available now
.

This error indicates that the System where the aborted job tried to run, does not have enough memory avaialbe to run the Job so it failed.

Please refer to your OS administrator for more information on freeing up or allocating additional memory to the machine where the AM Agent is installed.

 
Cause:
Cause type:
Other
Root Cause: The system has ran out of available memory.
Resolution:
This field was added on 30/03/2017. This article has not been updated yet. Refer to the "Description" or "Workaround" sections for solution information.

Fix Status: No Fix

Additional Information:
Workaround :
Restarting the AgentService and/or RmiServer processes will generally flush memory and allow the job to process normally.