Javelin not installed error when executing flows from TDM Portal

Document ID : KB000005294
Last Modified Date : 14/02/2018
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Issue:

When executing Javelin workflows from the TDM portal, we are receiving the following error message: 

Javelin not installed (not found in C:/Program Files(x86)/Grid-Tools/JavelinExecutor.exe )

We have Javelin installed on the E drive instead of the C drive.

Environment:
CA Test Data Manager (TDM)- TDM Web Portal and Javelin
Cause:

This error message is occurring because the TDM Portal is looking in its application.properties file to check the install location of Javelin. By default it is looking for javelin.install.folder=C:/Program Files(x86)/Grid-Tools/JavelinExecutor.exe. 

Resolution:

If your Javelin instance is installed in a different location, you can change the file path TDM Web Portal checks for to resolve this error message.

  1. Go to C:\Program Files\CA\CA Test Data Manager Portal\conf.
  2. Open the application.properties file.
  3. Search for 'javelin.install.folder'.
    • It probably says javelin.install.folder=C:/Program Files (x86)/Grid-Tools/Javelin
  4. Please change to javelin.install.folder= E:/Program Files (x86)/Grid-Tools/Javelin (or whatever file path you have Javelin installed in).
  5. Save the file.
  6. Restart the TDM Portal Service.
  7. Try to execute the Javelin flow from the Portal again.
Additional Information:

If you experience any further issues, please open a support case by going to https://www.ca.com/us/services-support/ca-support/contact-support.html.  

We also recommend looking at our Javelin troubleshooting page here: https://docops.ca.com/ca-test-data-manager/4-4/en/javelin/javelin-troubleshooting