java.net.SocketTimeoutException while using ECC

Document ID : KB000088028
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
java.net.SocketTimeoutException

While using the Enterprise Control Center (ECC), the above error is displayed.

Errors seen in the ECC Log:

 
2014-03-05 14:26:08,381 163948168 [http-bio-8080-exec-10] ERROR  
com.uc4.webui.vaadin.framework.MainApplication - Terminal error:
java.net.SocketTimeoutException: Read timed out

    at java.net.SocketInputStream.socketRead0(Native Method) ~[na:1.6.0_21]
    at java.net.SocketInputStream.read(Unknown Source) ~[na:1.6.0_21]
Environment:
OS Version: N/A
Cause:
Cause type:
Other
Root Cause: There is no fix for this, since it depends on third part Software.
Noted: ECC runs on (Vaadin) and Microsoft.
Resolution:
Update to Automation Engine 12 and use the Automic Web Interface (AWI). 

Fix Status: No Fix

Fix Version(s):
N/A
Additional Information:
Workaround :
This is a known issue that Automic is unable to provide a fix for as this is an issue with the third-party framework that the ECC runs on (Vaadin) and Microsoft. Vaadin support has determined that this issue cannot be fixed as there seems to be no possibility to solve this issue within the web application (http://dev.vaadin.com/ticket/8001).

There is a Microsoft KB regarding this which can be found here: http://support.microsoft.com/kb/895954 This KB includes a workaround that might work for you which can be found under "How to enable this hotfix". A Windows administrator should be consulted before taking those steps.