java.net.ConnectException: Connection refused - Cannot deploy VSM to VSE

Document ID : KB000097197
Last Modified Date : 19/05/2018
Show Technical Document Details
Issue:
VSE Service is up and running and available in the Workstation.
When deploying a Virtual Service Model to the VSE, the following is received:
 
java.rmi.RemoteException: JMS Messaging problem with ServerRequestHandler for tcp://VSEServer_FQDN:2013/VSE Could not connect to broker URL: tcp://VSEServer_FQDN:2013?wireFormat.maxInactivityDuration=0. Reason: java.net.ConnectException: Connection refused; nested exception is: 
com.itko.jms.JMSException: Could not connect to broker URL: tcp://VSEServer_FQDN:2013?wireFormat.maxInactivityDuration=0. Reason: java.net.ConnectException: Connection refused 
at com.itko.lisa.net.Transporter.init(Transporter.java:395) 
at com.itko.lisa.net.Transporter.<init>(Transporter.java:318) 
at com.itko.lisa.net.Transporter.createTransporter(Transporter.java:277) 
at com.itko.lisa.net.Transporter.getTransporter(Transporter.java:211) 
at com.itko.lisa.net.Transporter.transport(Transporter.java:160) 
at com.itko.lisa.net.Transactor.transact(Transactor.java:68) 
at com.itko.lisa.net.ClientBase.transact(ClientBase.java:361) 
at com.itko.lisa.net.ClientBase.invokeMethod(ClientBase.java:271) 
at com.itko.lisa.net.ClientBase.invokeMethod(ClientBase.java:244) 
at com.itko.lisa.net.VSEClient.getServiceNames(VSEClient.java:63) 
at com.itko.lisa.vse.ui.actions.DeployToVSEAction$1.doCallback(DeployToVSEAction.java:136) 
at com.itko.util.swing.panels.ProcessingDialog$2.run(ProcessingDialog.java:194) 
at java.lang.Thread.run(Thread.java:745) 
Caused by: com.itko.jms.JMSException: Could not connect to broker URL: tcp://VSEServer_FQDN:2013?wireFormat.maxInactivityDuration=0. Reason: java.net.ConnectException: Connection refused 
at com.itko.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:35) 
at com.itko.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:309) 
at com.itko.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:228) 
at com.itko.activemq.ActiveMQConnectionFactory.createQueueConnection(ActiveMQConnectionFactory.java:191) 
at com.itko.lisa.net.ActiveMQFactory.getRemoteQueueConnection(ActiveMQFactory.java:314) 
at com.itko.lisa.net.Transporter.getOrMakeConnection(Transporter.java:407) 
at com.itko.lisa.net.Transporter.init(Transporter.java:381) 
... 12 more 
Caused by: java.net.ConnectException: Connection refused 
at java.net.PlainSocketImpl.socketConnect(Native Method) 
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) 
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) 
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) 
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) 
at java.net.Socket.connect(Socket.java:589) 
at com.itko.activemq.transport.tcp.TcpTransport.connect(TcpTransport.java:497) 
at com.itko.activemq.transport.tcp.TcpTransport.doStart(TcpTransport.java:460) 
at com.itko.activemq.util.ServiceSupport.start(ServiceSupport.java:53) 
at com.itko.activemq.transport.InactivityMonitor.start(InactivityMonitor.java:127) 
at com.itko.activemq.transport.TransportFilter.start(TransportFilter.java:58) 
at com.itko.activemq.transport.WireFormatNegotiator.start(WireFormatNegotiator.java:72) 
at com.itko.activemq.transport.TransportFilter.start(TransportFilter.java:58) 
at com.itko.activemq.transport.TransportFilter.start(TransportFilter.java:58) 
at com.itko.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:289) 
... 17 more
Environment:
All Supported DevTest Releases.
Cause:
The machine where the Workstation is running is not able to connect to the VSE.
Resolution:
When facing this issue, test if the machine where DevTest Workstation is running is able to connect to the VSE.
You can use telnet with the VSE server name and the VSE Port, 2013 is the default port.
telnet VSEServer_FQDN 2013

If there is no connectivity between the Workstation and the VSE, the environment needs to be updated to allow the Workstation to communicate with the VSE and vice versa.
Additional Information:
For more information regarding DevTest Communications Requirements:
https://docops.ca.com/devtest-solutions/10-2/en/installing/preinstallation/system-requirements#SystemRequirements-CommunicationRequirements

For the default ports:
https://docops.ca.com/devtest-solutions/10-2/en/administering/general-administration/default-port-numbers#DefaultPortNumbers-DevTestWorkstationDefaultPortNumbers