Java HTTP error 500 error after upgrade to NFA 9.1.2

Document ID : KB000020271
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

And you cannot get to the NFA console web

Error - HTTP ERROR 500

Problem accessing /sso/sign-in-process.jsp. Reason:
PWC6033: Unable to compile class for JSP
PWC6197: An error occurred at line: 39 in the jsp file: /sign-in-process.jsp
PWC6199: Generated servlet error: ldapEncryption cannot be resolved or is not
a field at org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:123)
at org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:296)

Solution:

This customer was using Java version 1.7 from install of NFA 9.1.0, when they installed NFA`9.1.2 it 'comes' with Java 1.6.41. The clash of these twoversions caused this problem.

Customer uninstalled 1.6.41 to use 1.7 and all was then fine.

Solution - so make sure you do not install an older version of Java over a newer version. or uninstall the newer version first before upgrading.

For the CA NFA 9.1.2 install guide it says;

Java Runtime Engine (JRE) 1.6u41 which is included with the ISO files from CA Technical Support.