Java error while launching Support Automation analyst console in Firefox

Document ID : KB000007651
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

While trying to open the Support Automation analyst User Interface (UI) in Mozilla Firefox, the following error occurs:

"Analyst UI can't run without Java Runtime Environment (JRE) 1.6 or higher. Install JRE."

TEC1470929.png

Environment:
CA Service Desk Manager - ANY VERSION
Cause:

According to the below link, java is no longer supported in Firefox 52 and above.

 

https://www.java.com/en/download/help/firefox_java.xml

Java plug-in does not work in Firefox after installing Java


This article applies to:

  • Browser(s) Firefox
  • Java version(s): 7.0, 8.0

Firefox limits NPAPI support (technology required for Java applets)

64-bit Firefox

The 64-bit version of Firefox does not support NPAPI plug-ins, including Java.

Firefox 52 and above

Beginning with Firefox 52 (released March 2017), plug-in support is limited to Adobe Flash, and drops support for NPAPI, impacting plugins for Java, Silverlight, and other similar NPAPI based plugins.

 

If you have problems accessing Java applications using Firefox, Oracle recommends using Internet Explorer (Windows) or Safari (Mac OS X) instead. Developers and System administrators looking for alternative ways to support Firefox users should see this blog regarding Launching Web Start applications.

 

In addition, by opening the link https://www.java.com/en/download/installed.jsp from Firefox browser to verify java version, you might receive below message:

TEC1470929b.png

 
Resolution:

Java is no longer supported in Firefox 52 and above, neither in 64-bit release.

Consider to use other supported browsers to launch the Support Automation UI, such as Internet Explorer or Chrome.

In case Mozilla Firefox is still required, only Extended Support Release (ESR) will work as per the link mentioned above.

 

https://www.java.com/en/download/help/firefox_java.xml

Firefox 52 ESR 32-bit release

Mozilla offers an Extended Support Release (ESR) version of Firefox specifically for use by organizations who need extended support for mass deployments. Only Mozilla Firefox 52 ESR 32-bit release will continue offering support for the standards-based plugin support technology required to launch Java Applets. To see if you are using an ESR release, check the Firefox menu item (Help -> About) and looking for the "ESR" identifier.

 

Mozilla maintains Firefox ESR Releases for approximately one year. Developers and users still relying on the Java plugin technology in the 32-bit Mozilla Firefox web browser should consider migrating to a different solution.

 

 

Additional Information:

Check documentation for supportability matrix to consider using other supported browsers:

https://docops.ca.com/ca-service-management/14-1/en/release-information/supportability-matrix

https://docops.ca.com/ca-service-management/17-0/en/release-information/supportability-matrix

 

Links for reference:

https://www.java.com/en/download/help/firefox_java.xml

https://www.java.com/en/download/installed.jsp 

 

In case you see the same error in Chrome, try checking TEC1874892.

 

The information in this article has been included in our product documentation. You can find further details here:

https://docops.ca.com/ca-service-management/14-1/en/troubleshooting/troubleshooting-ca-service-desk-manager/the-support-analyst-user-interface-opens-in-firefox-with-an-error