Java error when Upgrade API Gateway 9.2 from 9.1 (Software)

Document ID : KB000005992
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

About upgrade API Gateway (9.1 -> 9.2).

It fails when API Gateway is upgraded after JKD is upgraded.

 

 

The process of upgrade:

01. Stop the CA API Gateway. 

02. Delete old java (jdk1.8.0_73). And install new java (jdk 1.8.0_102) (Because jdk 1.8.0_102 is requirements for 9.2.)

03. Set JAVA_HOME (expoert JAVA_HOME=/usr/java/jdk 1.8.0_102/jre)

04. Copy JCEPolicy to JAVA_HOME 

     #cp UnlimitedJCEPolicy/* /usr/java/jdk1.8.0_102/jre/lib/security/ 

05. Stop the slave in MySQL on all nodes in the cluster. 

06. Set the permissions and upload the relevant patch files to the CA API Gateway. 

     # chmod 755 /opt/SecureSpan/Controller/*.L7P 

     # /opt/SecureSpan/Controller/bin/patch.sh upload /opt/SecureSpan/Controller/ CA_API_Gateway_v9.2.00.L7P 

The following error appeared. 

Runtime error (check configuration): Error getting patch API: /usr/java/jdk1.8.0_73/jre/bin/java is not executable.”

Environment:
API Gateway 9.1 (Software) jdk1.8.0_73.API Gateway 9.2 (Software) jdk1.8.0_102.
Cause:

JAVA information is registered in API Gateway. 

Error occurs when actual JAVA is different from it. 

Resolution:

Do the following process. 

 

01. Upgrade gateway  without jdk upgrade. 

02. Upgrade jdk after the upgrade of Gateway is completed.

03. Do the following after JDK is upgraded.

      run /opt/SecureSpan/Gateway/runtime/bin/setup.sh 

      Select 2) Configure the Layer 7 Gateway ->   1) Java VM

      Set Java VM Path = “current Path of JAVA_HOME”

     

04. Modify /opt/SecureSpan/Controller/etc/host.properties.

      Host.jre=”current Path of JAVA_HOME”