Jaspersoft Studio Proxy Setup

Document ID : KB000124074
Last Modified Date : 03/01/2019
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Issue:
We have installed Jaspersoft Studio on our laptop (VDI) and are trying to connect the SaaS report server. But due to firewall / proxy rules we can not connect. We would like to get instructions on how to configure Jaspersoft Studio's proxy setup. We tried a few things but they are not working. We would also like to know how to get Jaspersoft Studio logs for troubleshooting. 
Cause:
The site's network does not have a SOCKS server, but the manual proxy setup dialog has SOCKS server fields that must be selected and defined. This is apparently caused by a JSFT Studio bug in release 7.1 and 6.4.2.
Resolution:

Workaround:

(1) add the loopback address for the device to the host field for SOCKS (i.e. 127.0.0.1)

(2) test the connection - it will initially fail in Studio 7.1

(3) remove the loopback address from the SOCKS field now, leaving it blank.

(4) retest the connection to the reports server

This workaround was evidently effective in JSFT Studio 7.1

Finding the Jaspersoft Studio error log: 

https://community.jaspersoft.com/wiki/finding-jaspersoft-studio-error-log