JasperSoft iReport Builder - Force iReport to use older version of Java (ver 6)

Document ID : KB000100900
Last Modified Date : 12/06/2018
Show Technical Document Details
Issue:
iReport does not launch with later versions of Java installed on the machine
Environment:
UIM 8.47 IReport. java jre.
Cause:
Multiple instances of java installed can cause IReport to not function.

 
Resolution:
https://community.jaspersoft.com/questions/500010/can-i-manual-select-jre-startup-ireport

Edit the file <ireport install dir>/etc/ireport.conf

There is a line to set a specific jre to use  (jdkhome="/path/to/jdk")

Uncomment it (removing the #) and set your favorite jdk. I assume you can use a jre too instead of a jdk