Jaspersoft Ad-hoc reports date filtering is setting the date to the prior day.

Document ID : KB000045550
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue: 
When filtering on a Jaspersoft ad-hoc report on the start date, the date keeps will get set to the day before the selected date.

Steps-to-Reproduce:

1. Go to Home > Advanced Reporting > Create > Ad-hoc View
2. Select Domain, e.g Project Domain
3. Select all attributes, e.g.
Project Name
Project ID
Start Date
Finish Date

Click OK.

4. Add selected attributes to the Columns.
5. Expand the fields needed including the field:

Start Date

6. In the results table, right-click on the column Start Date > Create Filter 

From the calendar picker, choose a date, e.g. August 2, 2016
Change the dropdown from "equals" to "is on or after".
Click Apply.

Check the filter Start Date .

Expected: The date should stay on 8/02/2016.
Actual: The date changes to 8/01/2016.

Cause:

This issue is due to defect CLRT-79518.

Workaround:

Save the Ad-hoc report view.
Search the Repository for the saved view.

The Ad-hoc report view can also be saved as a report to be ran
1. Immediately. Click the "Run Now" button
2. Scheduled. This can be performed by right-clicking the Ad-hoc Report > Schedule > Create Schedule

The reports will appear in the selected destination in the Repository.

 

Resolution:

This issue has been resolved as of Jaspersoft Server Cumulative Patch 6.2.1_5.2.1.1 for CA PPM.