ITPAM service not starting after installation

Document ID : KB000103900
Last Modified Date : 07/08/2018
Show Technical Document Details
Issue:
After installing CA Process Automation with version 4.3 SP02, service not starting..
Found below errors in boot.log:
--------------------------------------------------------------------
INFO [SystemPropertiesInitializer] Initialising System properties for PAM 
ERROR [SystemPropertiesInitializer] SQL Error occured while preparing properties table due to 
java.sql.SQLRecoverableException: IO Error: Connection reset 
at oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:498) 
Environment:
ITPAM version: 4.3 SP02
OS: Red Hat Linux 
Cause:
It is server/environment issue.
Resolution:
Add below two lines to c2osvrd.sh and pamactivemq.sh as below and restart the PAM service.

For c2osvrd.sh file:
  • Go to <PAM Install Path>/server/c2o/
  • Open c2osvrd.sh file
  • Add below two lines at the end of section "SVRDEFINES":   
              -Djava.security.egd=file:/dev/./urandom
              -Dsecurerandom.source=file:/dev/./urandom
  • Save and close the file.
For pamactivemq.sh file:
  • Go to <PAM Install Path>/activemq/bin
  • Open pamactivemq.sh file
  • Modify ACTIVEMQ_OPTS as below:
    from 
    ACTIVEMQ_OPTS="$ACTIVEMQ_OPTS_MEMORY -Djava.util.logging.config.file=logging.properties" 
    to 
    ACTIVEMQ_OPTS="$ACTIVEMQ_OPTS_MEMORY -Djava.util.logging.config.file=logging.properties -Djava.security.egd=file:/dev/./urandom -Dsecurerandom.source=file:/dev/./urandom" 
  • Save and close the file.