ITCM - Connector between ITCM and CA-SAM - Problem of duplicate devices

Document ID : KB000101426
Last Modified Date : 13/06/2018
Show Technical Document Details
Issue:

Connector CA Client Automation v2.6 for CA-SAM is generating some duplicate devices.

In CA-SAM output displays this :
 
----------------- Step 12/12 ----------------- 
... 
Statistics: 
- 400_itcm_devices.csv: 
Records: 9 
Actions: 9 
Inserted: 0 
Updated: 2 
Unaltered: 5 
Deleted: 0 
Errors: 2 
Invalid action: 2 
Most frequent errors: 
1. Duplicate found: import_id. (ASP-D7) (2 time(s)) 



 
In generated file like C:\Program Files (x86)\CA\SAM\app\uploads\demo\jobs\data_exchange\superuser\archive\1ecf1aa48e-400_itcm_devices.zip, I could see the duplicate row in 1ecf1aa48e-400_itcm_devices.csv

 
Environment:
CA Client Automation Connector v2.6 for CA-SAM
Cause:

This problem occurs if a machine has 2 or more processors with different value for processor speed :


Example : 

Intel Core i7 2700
Intel Core i7 2750



 
Resolution:

Open a CA Support Case asking for fix T5SD190 for CA Client Automation Connector v2.6 for CA-SAM
 

PROBLEM SYMPTOM: WIN-ITCM - CONNECTOR BETWEEN ITCM AND CA-SAM      
                 ----------------------------------------------------
                 Currently the interface when creating devices
                 generate duplicates and a record can not be
                 updated or created in SAM, if it is a duplicate. 
                 
                 For servers, duplicates come from dual processors
                 that have different frequencies. The information
                 is correct in ITCM, 
                 but the interface can not handle these dual
                 frequencies and creates a device (server) record
                 for each processor frequency.