Issues while running DB load utility for AE V9.x

Document ID : KB000102324
Last Modified Date : 25/06/2018
Show Technical Document Details
Issue:
Issue:  When doing an initial load of the Automic database object into an Oracle database, the AutomicDBLOAD utility encountered error.
(When executing command "ucybdbld -B -X/opt/Automic/Utilities/db/general/9.00A/UC_UPD.TXT")

Error message:
20180612/140749.249 - U0029108 UCUDB: SQL_ERROR Database handles DB-HENV: a3ebc0 DB-HDBC: 0
20180612/140749.249 - U0003591 UCUDB - DB error info: OPC: 'OCIStmtExecute' Return code: 'ERROR'
20180612/140749.249 - U0003592 UCUDB - Status: '' Native error: '12899' Msg: 'ORA-12899: value too large for column "UC4"."DIVDB"."DIVDB_STRING" (actual: 384, maximum: 255)'
20180612/140749.249 - U0003590 UCUDB - DB error: 'OCIStmtExecute', 'ERROR ', '', 'ORA-12899: value too large for column "UC4"."DIVDB"."DIVDB_STRING" (actual: 384, maximum: 255)'
20180612/140749.249 - U0003531 UCUDB: Error while checking data source (e.g. code conversion or driver problem, see log file).
20180612/140749.249 - U0003594 UCUDB Ret: '3590' opcode: 'OPEN' SQL Stmnt: ''
20180612/140749.249 - U0003590 UCUDB - DB error: 'OCIStmtExecute', 'ERROR ', '', 'ORA-12899: value too large for column "UC4"."DIVDB"."DIVDB_STRING" (actual: 384, maximum: 255)'
20180612/140749.249 - U0038091 Change application directory to '../db/'.
20180612/140749.249 - U0003590 UCUDB - DB error: 'OCIStmtExecute', 'ERROR ', '', 'ORA-12899: value too large for column "UC4"."DIVDB"."DIVDB_STRING" (actual: 384, maximum: 255)' Application return code = 1


 
Environment:
Upgrading from AE v9 to AE v12, error at stage loading DB
Database : Oracle 11.2
Resolution:
Investigation
  • Checking the DBLOAD log you see the following line for the database set-up:
U0003535 DB INFO: 'NLS_LENGTH_SEMANTICS = BYTE'
Solution 1:
  • The database need to be set up to use CHAR per the documentation the database must be set with UTF-8 and NLS_LENGTH_SEMANTICS = CHAR.
Solution 2:

 

 

  • Install the full version of Oracle DB instead of using Oracle XE version with limitation options
Additional Information: