Issues accessing CA Output Management WebViewer 12.1 via F5 load balanced URL

Document ID : KB000007053
Last Modified Date : 14/02/2018
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Issue:

When accessing CA WebViewer r12.1 via an F5 load balanced URL, users are being intermittently routed back to the login page when interacting with the system. There is no pattern, it can happen at any time. 

When users target an IHS web server directly, no issues are reported. When accessing directly via a single F5 LTM the issue is also present. 

Within the WebSphere Application Server we can see a situation where the session remains within WAS and where the session is invalidated and it is successfully removed from memory.

Our environment does not have persistence enabled on the F5s but we’d like to avoid this scenario if possible to ensure that we balance the traffic evenly across our infrastructure when a server is recovered. 

However, we suspect that the application does not like requests coming in from different IPs for the same session.

Environment:
F5 Load Balancer
Cause:

Server affinity is required when load-balancing Web Viewer and had not been specified.  If the user is routed to a different server while logged in, they are forced to login again (and the prior session is orphaned until it expires or times out).

Resolution:

Web Viewer has session information specific to the web server instance for each login. Server affinity is required when load-balancing Web Viewer

Additional Information: