IM server is not available at xxx.xxx.xxx.xxx:8080. Not Found

Document ID : KB000108157
Last Modified Date : 08/08/2018
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Issue:
When attempting to configure the connectivity between Identity Governance and Identity Portal an error message is received:
IG portal ui error:
IM server is not available at xxx.xxx.xxx.xxx:8080.

In Eurekify.log
"WebServiceHandler.getJSONObject: 3 attempts have failed to get object type configuration from IM. Return status is: Not Found
WebServiceHandler.getJSONObject:  Failed to get information from IM for managed object type configuration: Failed to get information from IM for managed object type configuration:"

The connectivity from IG to IM and back is configured in several locations and often one of the actions is missed. Here is a list of a few things to watch out for.
Environment:
Identity Manager Suite 14.1
Cause:
The connectivity has a lot of 'moving parts' and need to be set in several places. If any part of these configurations is not done correctly the connectivity breaks.
Resolution:
1) Make sure IMRCM role has 'Create Web Services Configuration' in IM 
2) Make sure the user you are using to test the connection is added as Export Administrator in IM: 
IM user console->System->CA RCM Configuration-> Change Export Administrator - needed to add his user here
3) Delete the IMRCM Web Services - System > Web service. Access IG and run test for the connector. The Web Service will be recreated.