issue after SSL configuration on SPS

Document ID : KB000116296
Last Modified Date : 28/09/2018
Show Technical Document Details
Question:
I configured SSL on our CA Siteminder 12.52 environment. Once I created key and certificate server, and configured SPS I cannot restart SiteMinder Secure Proxy Service on Windows. I need to create a Federation partnership so for this I needed to configure SSL on the environment, but now SPS does not start correctly.

When checking the SPS logs, I do see the following messages in server.log: 
[21/oct/2018:09:17:40-542] [INFO] - ** Error parsing config file 'C:\Program Files (x86)\CA\secure-proxy\proxy-engine\conf\server.conf'. 
[21/oct/2018:09:17:40-542] [INFO] - ** Line No   : '465' 
[21/oct/2018:09:17:40-542] [INFO] - ** Line Text : '<VirtualHost name= myserver.domain.com:443>' 
[21/oct/2018:09:17:40-542] [FATAL] - tomcat.fatalconfigerror 
[21/oct/2018:09:17:40-542] [FATAL] - FATAL: error parsing config file 'C:\Program Files (x86)\CA\secure-proxy\proxy-engine\conf\server.conf' 
[21/oct/2018:09:17:40-542] [FATAL] - FATAL: Server exiting in 5 seconds ... 


I have checked server.conf (Line 465) but I do not see anything wrong: 
<VirtualHost name= myserver.domain.com:443> 
    #addresses="192.168.1.100" 
    hostnames="myserver.domain.com" 
    defaultsessionscheme="default" 
    # specify the block size for request and response in KBs 
    requestblocksize="4" 
    responseblocksize="8" 
</VirtualHost> 


Could you help me to identify what is wrong and how to solve this issue?
Answer:
The problem comes from the VirtualHost missing the quotes, so changing the following: 
<VirtualHost name= myserver.domain.com:443> 
by adding the quotes, like: 
<VirtualHost name="myserver.domain.com:443"> 
will solve this problem.