Is Spectrum vulnerable to CVE-2017-12621 vulnerability?

Document ID : KB000016260
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

CVE-2017-12621 vulnerability describes that during Jelly (xml) file parsing with Apache Xerces, if a custom doctype entity is declared with a "SYSTEM" entity with a URL and that entity is used in the body of the Jelly file, during parser instantiation the parser will attempt to connect to said URL. This could lead to XML External Entity (XXE) attacks in Apache Commons Jelly before 1.0.1.

Question:

Is Spectrum affected by this CVE-2017-12621 vulnerability?

Environment:
All Spectrum versions
Answer:

No, Spectrum is not affected by this vulnerability. Spectrum is not using Apache Commons Jelly.

Additional Information:

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-12621