Is node.js instrumentation supported out of the box? What versions are supported?

Document ID : KB000030368
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

Is node.js instrumentation supported out of the box? What versions are supported?

 

Solution:

Version Support

Node JS is supported with APM 9.7.1.  The node.JS monitoring requires new RESTful EPA Agent 9.7.1. 

Both Node JS .10 and .12 are officially supported with CA APM 9.7.1.

 

Documentation

The ca-agent installation is well-documented on npmjs.com page:  https://www.npmjs.com/package/ca-agent

Official documentation is also located on the CA wiki:  https://wiki.ca.com/display/APMDEVOPS97/StrongLoop+%7C+CA+Agent+for+Monitoring+Node.js+Applications