Is Java Development Kit (JDK) required for Web Viewer? If only a JRE is needed, can we remove JDK and install JRE? What bitness is required?

Document ID : KB000011789
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

Is Java Development Kit (JDK) required for Web Viewer? If only a JRE is needed, can we remove JDK and install JRE? What bitness is required?

Question:

We Deploy a CA-Web Viewer ear file onto a WebSphere server. Our Server Vulnerability Management team identified JDK (Java Development Kit) and they are going to update JDK to 8u111. JRE should be 64 bit?

Environment:
This applies to all supported Web Viewer / Operating System environments.
Answer:

WebSphere provides its own JRE. You will have to speak with WebSphere Support about which JRE/JDK it is using. That said we only require a JRE and it should be 64bit.

Additional Information:

64 Bit is recommended because while a 32 Bit JRE may work, it is likely to introduce performance problems.