IPCV screen showing wrong version after IPC and Ideal upgrade

Document ID : KB000108535
Last Modified Date : 31/07/2018
Show Technical Document Details
Issue:
All the IPC and Ideal upgrade jobs (from 14.0 to 15.0) completed successfully (i.e. RC 0).

When entering the Ideal @I£INTERNAL STATUS command, it shows that version 15.0 is in place IDEAL:
Product information IDEAL 15.0 RELEASE LEVELS IPC VERSION: 15.0 D-D VERSION: 15.0 D-B VERSION: 15.0
 
However the IPCV logon panel shows release 14.0 rather than 15.0.

CICS region is using the newly allocated 15.0 VLS libraries.
Environment:
Ideal/IPC 15.0
Cause:
The error is on upgrade jobs.
IPC 15.0 job VQUPG01 was run first; it copied 14.0 ADRPNL and ADRLIB to the 15.0 files and then updated the 15.0 VLS members.

Later on Ideal job ILCUS03 was executed; it copied once again 14.0 ADRPNL and ADRLIB to the 15.0 files but in this way the 15.0 VLS members previously updated by VQUPG01 were overwritten by the corresponding 14.0 ones. This step is NOT required if IPC has been just upgraded and Ideal is using the same VLS libraries that have been just allocated/initialized by IPC 15.0 upgrade.
Resolution:
The quickest method is to re-run on the current ADRPNL and ADRLIB libraries only the RESTORE NOCLEAR(R) part of the VQUPG01 job.