Introscope won't start after upgrade - Application "com.wily.introscope.em.application" could not be found in the registry.

Document ID : KB000009123
Last Modified Date : 14/02/2018
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Issue:

After upgrading an Enterprise Manager (with no errors in the install log), it fails to start. The IntroscopeEnterpriseManager.log has an entry similar to the following:

 

!ENTRY org.eclipse.osgi 4 0 2018-01-11 15:21:31.399 

!MESSAGE Application error 

!STACK 1 

java.lang.RuntimeException: Application "com.wily.introscope.em.application" could not be found in the registry. The applications available are: org.eclipse.equinox.app.error. 

at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242) 

at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29) 

at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)

 

 

Environment:
A recently upgraded EM
Cause:

This error indicates a problem with the OSGI files - this can be caused by either leftover OSGI files from the previous version, or required files being missing/corrupted.

Resolution:

  To fix the error:

  -Rerun the installer again - in most instances this will fix the problem

  OR

 -Replace the following folder with a copy from a working EM of the same version (or a new install of the EM):

 <EM_HOME>\product\enterprisemanager\plugins\

  The OSGI and product files are all contained within there - replacing these files with a working copy (of the same version) will resolve the problem.