Introscope installers fail or will not start

Document ID : KB000111991
Last Modified Date : 23/08/2018
Show Technical Document Details
Issue:
You launch the Introscope installer, after a few minutes, a pop up dialog shows one of the below error messages:

In Windows:

- "LaunchAnywhere Error
Windows error 2 occured while loading the Java VM"

"LaunchAnywhere Error
Could not find a valid jvm to load"

-"Installer UI Mode Error
Installer User Interface Mode Not Supported
The installer cannot run in this UI mode. To specify the interface mode, use the -i command-line option, followed by the UI mode identifier. The valid UI modes identifiers are GUI, Console and Silent"

- "The Application has Unexpectedly Quit
Invocation of this Java Application has caused an
InvocationTargetException. This application will now exit(LAX)"


Clicking the details button gives you the below information:

"lexeraax2$aaa: C:\Users\Administrator\AppData\Local\Temp\I1471938879\Windows_Pure_64_Bit\resource\iawin32.dll not found
    at Flexeraax2.af(Unknown Source)
    at Flexeraax2.aa(Unknown Source)
    at com.zerog.ia.installer.LifeCycleManager.init(Unknown Source)
    at com.zerog.ia.installer.LifeCycleManager.executeApplication(Unknown Source)
    at com.zerog.ia.installer.Main.main(Unknown Source)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.zerog.lax.LAX.launch(Unknown Source)
    at com.zerog.lax.LAX.main(Unknown Source)"


In Unix: 
 
“Preparing to install...
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...
 
Launching installer...
 
JRE libraries are missing or not compatible....
Exiting....
Environment:
Platform:
  • Windows and Unix
 
Affected components:
  • Enterprise Manager
  • Workstation
  • Java installer
  • Powerpack Installer
  • APM Integration Pack ADA
  • APM cloud monitor
 
 
Cause:
The problem is related to the third-party software InstallAnywhere

Related defects:  TT#79738  (Agent),  DE197883 (EM)

CA Technologies plans to fix this issue by upgrading InstallAnywhere to latest version in a future releases
 
Resolution:

Workaround:

1) Download and install JRE 1.8 u45 64bit or previous version 

2) Launch the APM Introscope product installer or uninstaller using the following syntax:
<installer (.exe) LAX_VM <path to JRE JRE 1.8 u45 64bit or previous version >\bin\java.exe

For example:

a) Introscope EM standard and SAP versions:

introscope10.3.0.15windowsAMD64.exe LAX_VM "C:\Program Files\Java\jdk1.8.0_45\bin\java.exe"
introscope10.5.2.91windowsAMD64SAP.exe LAX_VM "C:\Program Files\Java\jre1.8.0_45\bin\java.exe"
Uninstall_Introscope.exe LAX_VM "C:\Program Files\Java\jre1.8.0_45\bin\java.exe"

b) Workstation:
IntroscopeWorkstation10.5.1.8windows.exe LAX_VM "C:\Program Files\Java\jre1.8.0_45\bin\java.exe"
In Unix:
./IntroscopeWorkstation10.5.2.24linux.bin LAX_VM /jre1.8.0_45/bin/java

c) Agent
Install.exe LAX_VM "C:\Program Files\Java\jre1.8.0_45\bin\java.exe"

d) Powerpack:
IntroscopeStandaloneAgentPP10.5.2.15windows.exe LAX_VM "C:\Program Files\Java\jre1.8.0_45\bin\java.exe"
 
e) ADA extension:
APMIntegrationPackADA10.5.2.15windows.exe LAX_VM "C:\Program Files\Java\jre1.8.0_45\bin\java.exe"
 
f) APM cloud monitor:
APMCloudMonitor10.5.2.15windows.exe LAX_VM "C:\Program Files\Java\jre1.8.0_45\bin\java.exe"