Internal Web Service ignores Client Separation

Document ID : KB000084684
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
N/A

The internal Web Service ignores Client separation when using service methods such as: "getReports", "setTaskState" or "getTaskDetails".

It is possible to get access to Task, Details, etc. from other Clients.
Cause:
Cause type:
Defect
Root Cause: There is a missing check to get access to Task, Details, etc. from other Clients.
Resolution:
Update to a fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Automation Engine 12.1.1 - Available
Automation Engine 12.0.4 – Available
Automation Engine 11.2.7 – Available
Additional Information:
Workaround :
N/A