Intermittent 'Synchronization Failure' errors with CABI data source

Document ID : KB000125506
Last Modified Date : 30/01/2019
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Issue:
We're seeing an intermittent 'Synchronization Failure' errors with CABI data source, and logs indicate "A processing failure occurred on the data source during synchronization"
Environment:
CAPM 3.x
CABI 6.3.0
Cause:
During installation of PM content to CABi server installer add CABISynch.war, jar and xml files for custom jasper data source and js+jsp files for reports, and generates capm.properties and capm.jks files in <CA Business Intelligence>/apache-tomcat/webapps/jasperserver-pro/WEB-INF/config. These properties and jks files must be on both PC and CABI for SSO to work. 

There is no capm.properties nor capm.jks files on the CABI system.
 
Resolution:
Re-run the CAPM-CABI integration script to replace any missing config files
Additional Information:
https://docops.ca.com/ca-performance-management/3-6/en/integrating/integrate-ca-business-intelligence/install-ca-business-intelligence-reports-and-dashboards