Integration Process fails on Service Management installation

Document ID : KB000112128
Last Modified Date : 29/08/2018
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Issue:
Customer is installing the Service Management 17.1 and it fails in 'Integration Process' step.
Checked for installation the following components:
Service Desk Manager
Service Catalog
xFlow
Search Server
EEM
Collaboration
Datamart
And all the patches
Environment:
Service Management 17.1
Cause:
The MSSQL component was missing on the Server: SQLncli (not installed)
It caused a BAD Service Desk Manager Configuration, due to database connection failure.
The SDM configuration did not finish successfully.
Despite of the failure on SDM, the installation continue installing all of other components, however in the Integration process, it failed due to the Service Desk is corrupted.
Resolution:
Restore a snapshot of Server and database.
Install the SQLncli component in the Server.
Restart the installation.