Integration CAPC Jasper message An error occurred retrieving reports. Please check the logs for details

Document ID : KB000111685
Last Modified Date : 30/01/2019
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Issue:
Messages:
On CAPC web page: An error occurred retrieving reports. Please check the logs for details.

On CAPC wrapper-*.log file:
GET request for "http://nnn.nnn.nnn.nnn:8080/jasperserver-pro/rest_v2/resources?folderUri=/public/ca&recursive=true&type=reportUnit&type=dashboard&jaspertoken=fMBFEKomRju/3clZMjyEgQ==??rbt&orgidl=CAPM" resulted in 401 (Unauthorized); invoking error handler

Failed to retrieve reports

org.springframework.web.client.HttpClientErrorException: 401 Unauthorized

 
Environment:
PM 3.x
CABI 3.6
Cause:
The upgrade doesn't copy the new files for the CAPC machine
 
Resolution:
Logon on CAPC machine

1) Stop CAPC Services

2) Rename the files:
capm.properties
capm.jks
in /PC/webapps/pc/WEB-INF/CABIKeystore folder

3) Copy the news files:
capm.properties
capm.jks

From (CABI machine):
/jasperserver-pro/WEB-INF/config

To (CAPC machine)::
/PC/webapps/pc/WEB-INF/CABIKeystore

4) Start CAPC Services
Additional Information:
https://docops.ca.com/ca-performance-management/3-6/en/integrating/integrate-ca-business-intelligence/install-ca-business-intelligence-reports-and-dashboards#InstallCABusinessIntelligenceReportsandDashboards-ConfigureUserSynchronizatio