Installing Analytics on Premise on Linux via the AutoInstall Folder results in 'Unresolved constraint' error

Document ID : KB000087433
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
[FelixStartLevel] ERROR ECC BOOT - org.apache.felix.framework.Felix[com.automic.analytics.webui-plugin-analytics [85]] Error starting/stopping bundle.
org.osgi.framework.BundleException: Unresolved constraint in bundle com.automic.analytics.webui-plugin-analytics [85]: Unable to resolve 85.0: missing requirement [85.0] osgi.wiring.package; (&(osgi.wiring.package=com.vaadin.annotations)(version>=7.7.0)(!(version>=8.0.0)))
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) ~[org.apache.felix.main-4.4.1.jar:na]
at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) ~[org.apache.felix.main-4.4.1.jar:na]
at org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1491) ~[org.apache.felix.main-4.4.1.jar:na]
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:334) [org.apache.felix.main-4.4.1.jar:na]
at java.lang.Thread.run(Thread.java:748) [na:1.8.0_144]

During the installation of  Analytics on Premise the following Error Message appears:
[FelixStartLevel] ERROR ECC BOOT - org.apache.felix.framework.Felix[com.automic.analytics.webui-plugin-analytics [85]] Error starting/stopping bundle.org.osgi.framework.BundleException: Unresolved constraint in bundle com.automic.analytics.webui-plugin-analytics [85]: Unable to resolve 85.0: missing requirement [85.0] osgi.wiring.package; (&(osgi.wiring.package=com.vaadin.annotations)(version>=7.7.0)(!(version>=8.0.0)))at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) ~[org.apache.felix.main-4.4.1.jar:na]at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) ~[org.apache.felix.main-4.4.1.jar:na]at org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1491) ~[org.apache.felix.main-4.4.1.jar:na]at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:334) [org.apache.felix.main-4.4.1.jar:na]at java.lang.Thread.run(Thread.java:748) [na:1.8.0_144]
AWI is running on Tomcat correctly only when attempting to install the Analytics WEB UI PlugIn via the Autoinstall Folder does it result in the above mentioned error message.



 
Environment:
OS Version: N/A
Cause:
Cause type:
Configuration
Root Cause: Version mismatch. After reviewing the logfiles (Tomcat Framework) and installation file, it was concluded that the installed version did not correspond to the WEBUI 12.0.3. The installation still looks like it is a 12.0.0 or at most 12.0.2. In particular, the ROOT war still contains vaadin in version 7.6.3 while WEBUI 12.0.3 bundles vaadin version 7.7.9.
Resolution:
Correct the version mismatch by upgrading the system from 12.0.1 to 12.0.3.

Then the webui-plugin-analytics can be successfully installed.

 

Fix Status: No Fix

Fix Version(s):
N/A
Additional Information:
Workaround :
N/A