Installing a PAM cluster and the node2 install will not launch

Document ID : KB000020403
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

When installing an ITPAM cluster, it is necessary to launch the node2 install (or any subsequent node install) from the first node by logging into the first node, going to the Configuration tab and selecting Installation. Then installing the second node from the choices listed there. In some cases, when launching the second node install from a Windows machine, the download takes place but then the javaw.exe process ends and no install is ever launched. This doc will explain what is going on and how to fix it.

Solution:

Several things happen when you launch the node2 install from node1. Browser permissions have to be set to that the exe can be downloaded to your local node2 machine. The exe is downloaded to the temp directory of the user you are logged in as. If you are not sure what directory that is, you can run the "set" command from a command prompt and check the TEMP variable path. In this temp directory you will see the Third_Party_Installer_windows_32.exe (or Third_Party_Installer_windows_64.exe). This is the file that is being downloaded when you click to install node2 from the node1 interface. Once this file downloads, an attempt will be made to launch the exe. If there are any sort of permissions problems, you will not see them, but instead the install will seem to die and not progress any further after the download is complete.

First, make sure you are logged into the local machine as a user with local administrator rights before launching the install. Also, make sure the file size of the exe has stopped growing before assuming it isn't doing anything. You can refresh your windows explorer window to see the change in file size.

So if you have a completely downloaded exe and nothing is happening, this can be due to a block by the Windows User Account Control. Disabling UAC temporarily can get you past this problem. To do that:

On the node2 machine, go to Start>Control Panel and select User Accounts.

Figure 1

This screen may be different depending on the version of Windows you are running. But you see above there is a choice for "Turn User Account Control on or off". This may also say "Change User Account Control Settings". Click this choice.

Figure 2

Uncheck the checkbox and click OK. This may require a reboot. (On some Windows versions you may see a slider that you can slide to "Never Notify".)

Now delete the exe from the temp directory and return to the ITPAM node1 interface and launch the install for node2 again.