Installers web page hosted by primary hub fails to load

Document ID : KB000107621
Last Modified Date : 23/07/2018
Show Technical Document Details
Introduction:
The following error appears when trying to access the UIM 8.51 Installers web page hosted on the primary hub:

An unexpected system error occurred.   javax.servlet.jsp.JspException: org.apache.velocity.exception.ResourceNotFoundException: Unable to find resource '_SERVLET_CONTEXT_/html/themes/_unstyled/templates/init.vm'
Question:
What can be done to prevent the occurrence of the unexpected system error when trying to access the Installers page from the UIM home web page on the primary hub?
Environment:
UIM 8.51
UIM 8.51 SP1
Answer:
The recommended solution is to delete the wasp probe on the primary hub and redeploy as follows:

1.  Delete the wasp probe from the primary hub
2.  Delete the wasp directory and its contents from the primary hub server (found under the <installPath>\Nimsoft\probes\service directory)
3.  Deploy the latest version of the following packages in the following order to your primary hub:

- wasp
- uimhome
- mps
- adminconsoleapp

4.  Activate the wasp probe on the primary hub

The problem is most likely caused by corrupt file(s) under the wasp\webapps\ROOT directory.  Deleting then reinstalling will resolve this issue.

Please note that this procedure assumes that the UMP portal is installed on a robot other than the primary hub.  If the UMP is also deployed on the primary hub, then follow the instructions in the following Knowledge Document to resolve this issue instead:

KB000035078 : UMP error javax.servlet.jsp.JspException: org.apache.velocity.exception.ResourceNotFoundException: Unable to find resource '_SERVLET_CONTEXT_/html/themes/_unstyled/templates/init.vm'