Installation script would not start because library libbz2.so.1. is not found.

Document ID : KB000039081
Last Modified Date : 14/02/2018
Show Technical Document Details

Symptoms:

When trying to install WAAE, the installer (wa_setup.sh) returns: 

Unable to locate required library libbz2.so.1. Possible path problem or missing RPM package. Exiting with return code <8>.

Cause:

A package is missing and needs to be installed. 

Resolution: 

Use yum provides to get the name of the package containing the missing library: 

yum provides /lib/libbz2.so.1

 You will get a reply like: 

Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity
base/filelists                                                  | 3.3 MB     00:00
bzip2-libs-1.0.5-7.el6_0.i686 : Libraries for applications using bzip2
Repo        : base
Matched from:
Filename    : /lib/libbz2.so.1

 You just need to install the package listed above (bzip2-libs-1.0.5-7.el6_0.i686):

 sudo yum install bzip2-libs-1.0.5-7.el6_0.i686 -y

 

Then run the installer again and the installation should go smoothly.