Installation of MSP interface on 14.2 results in a SilentInstallAddin error

Document ID : KB000031129
Last Modified Date : 14/02/2018
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Problem:

When installing the 14.2 MSP interface, whether a new install or an upgrade install, a SilentInstallAddin error pops up. You must select Close the Program to proceed with the installation. The installation then finishes.

Steps to Reproduce:

  1. On PPM v14.2, go to Home, Account Settings, Software Downloads 
  2. Click 'Download' link for either 'Microsoft Project Interface (x86)' or 'Microsoft Project Interface (x64)' (depending on your requirement) 
  3. Run and complete the installation by clicking on each prompt
Expected Result: Installation completes without error
Actual Result: A "SilentInstallAddin has stopped working" error is thrown, which will need to be closed before the installation can continue 

Environment: 

Applies to all supported PAS environments for specified releases.  

Cause:

Caused by CLRT-77518

Resolution

Resolved in CA PPM 14.2 Generic Patch #3.  

Resolved in CA PPM 14.3  

Additional Information: 

Reference TEC613901 : Should I install the x86 or x64 version of the Microsoft Project Interface?

Reference TEC1398937  : PPM 14.2 Generic Patch available to resolve reported issues

 

Reference CA PPM Resolved Defects Index for CA PPM 14.3