Insights integration - Xflow is not working after restart Jaspersoft

Document ID : KB000107491
Last Modified Date : 20/07/2018
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Issue:
Integration between SDM -xFlow -Jaspersoft -Datamart issue.

After restart Jasper services, the Insight integration stop working, when they give click to "Insight" button, nothing happens.
Environment:
SDM
Xflow, Insights
Jaspersoft
Datamart



 
Cause:
Customer execute Xflow re-installation process. But but during this process the server name was changed from  <old_servername>  to <new_servername>.

It provokes some Xflow registers keep old servername.

Reviewing the Xflow logs, we can see  Xflow service is not starting rightly.

In the IncidentMS.log file the follow message is found:

WARN - <date> [a.remote.ReliableDeliverySupervisor] - Association with remote system [akka.tcp://Incident_MicroService_XflowClusterSystem@<old_servername>:<port>] has failed, address is now gated for [5000] ms. Reason: [Association failed with [akka.tcp://Incident_MicroService_XflowClusterSystem@<old_servername>:<port>]] Caused by: [<old_servername>]
Resolution:

NOTE: Take backup from mdb database before to do any change!
================================================


1) Select the xflowClusterSystem entries from l1admin_general_config:
 
select * from l1admin_general_config where config_value like '%xflowClusterSystem%'

verify the rows display the right servername.



2) Default entry  for '%xflowClusterSystem%'  should be id=400001, if it has invalid value, it needs to be modified:

User-added image
 
update [mdb].[dbo].[l1admin_general_config]
set config_value ='akka.tcp://Incident_MicroService_XflowClusterSystem@<new_servername>:<port>'
where id =400001



3) If any additional row has invalid name, take the id and delete the invalid reference:

User-added image
delete
FROM [mdb].[dbo].[l1admin_general_config] where id =XXXXX

where XXXX has the ID of the invalid value, in this case 400051.



4) Restart services and test the integration again.
 
Additional Information:
Xflow logs are found in
  • <Install Drive>\CA\xFlow\APPS\logs