Input Type Code & Charge Codes deleted incorrectly for some tasks in the CA PPM New UX

Document ID : KB000098851
Last Modified Date : 22/06/2018
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Issue:
In the New User Experience (UX), the Task Input Type Code and Charge Code are unexpected deleted for some tasks after copying the previous week's timesheet data into the current week. 

Steps to Reproduce:
  1. Log in to PPM and navigate to the new UX timesheets
  2. For the previous time period (i.e. April 16 - April 22), have a submitted timesheet with tasks from at least 3 different projects
  3. Go the current time period (i.e. April 23 - 29) and use the 'Copy previous timesheet (April 16 - April 22)' function
  4. Give each individual task a Input Type Code and Charge Code value so that these are all populated for the tasks 
  5. Delete the last task from the last project you have tasks for in your copied timesheet 
  6. Add that task back using the '+ Work' button (such that you are back to having at least 2 different projects listed on your timesheet) 
  7. Populate the Input Type Code and Charge Code for that added task 
  8. Delete the Charge Code and/or Input Type Code that you just entered for that added task 
Expected Results: The Charge Code/Input Type Code should be deleted for just that task 
Actual Results: The Charge Code/Input Type Code is deleted for that task and from one of the tasks above it 
Cause:
This is caused by DE40892 
Resolution:
This issue is currently under investigation.

Workaround:
Switch from the timesheet of the current period to the one of the previous period, and then back to the current period seems to fix it. After that, modifications on the Input Type Code/Charge Code of one task do not seem to impact the field on other tasks. 
 
Additional Information:
Reference KB000093171 - What are the known New User Experience (UX) defects?
Reference KB000093166 - Where can I find New User Experience (UX) knowledge documents?