Infrastructure Manager Groups Node (How to create and work with IM Groups)

Document ID : KB000010343
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

The Infrastructure Manager (IM) Groups Node- How to create and work with IM Groups.

Environment:
- UIM 8.x or higher
Instructions:

The Infrastructure Manager (IM) creates groups which are not in the database. They are stored locally on each machine.

The local user needs to save their local IM profile if they create their own groups and want them to show up after logging out and back in again.

Also, note that the Groups node will be hidden if the option 'Show Groups node' is NOT selected in the Tools->Options dialog window.

***The IM profiles are stored under ...\hub\profile

You can test this by creating a new profile on the local machine/laptop youre using and logging in as different users that have that profile associated with their login as per User Administration.

Note that a user needs to have the ability to write to the <nimsoft>\lib directory on the machine on which IM is running in order to put the pcf file in there.

***When you log back in to the IM you can open your previously saved profile to see the groups you created.

Profiles are saved 'per-hub.'

Users should hit the "key" icon in the IM to log in and make sure to choose the primary hub from the list and then see if the profile/groups persists for all users logged into that hub.

If the same Nimsoft login on a different machine has different results check the rights of the userID to log into the machine and check if the user has the ability to write to the <nimsoft>\lib directory on the machine on which IM is running in order to put the pcf file in there if copying the pcf file to a hub and restarting it.

How to enable Infrastructure Groups option/node in the Infrastructure Manager (IM) and create an Infrastructure group:

    - In Infrastructure Manager, go to the "Tools->Options" menu
    - Check the "Show Groups node" checkbox in the login section, upper right-side of the window
    - Click on <OK>. That should activate the groups for you.
    - Create Infrastructure Groups in NMS.
    - Right click on HUB --> New -->Infrastructure Group

The Groups Node may contain user-composed groups of Probes, Robots or Hubs.

It is often useful to group a set of Probes to simplify configuration and to speed up the task of locating the Probe in a large environment.

Distributing a probe package to a group of Robots, the probe package will be distributed to all Robots in that group.

You may also group a set of Probes related to a specific task, e.g. a database administrator needs to configure/monitor database Probes as well as a disk monitoring Probe (cdm).

By clicking one of the groups, all defined elements under that group will be displayed in the Main Window Pane.

For convenient fast access to a group of Hubs in the IM you could create a Hub Infrastructure Group based on location, e.g.,

- US_Hubs
- UK_Hubs

Double click on the domain in the navigation pane to see a list of hubs you can drag and drop into the appropriate Group. Rt-click to Edit a Group to Add or Remove an item/entry.

Note that in the web-based Admin Console, you can list all Hubs via the Menu option->Hubs and you can use the Filter function to easily locate any Hub based on its name.

To delete Groups no matter what profile they are in within Infrastructure Manager, do the following:

Since this is a per machine/instance of IM:

1. In IM, go to View-> Manage Profiles.
2. Delete all profiles that show up under Manage Profiles, not just 'default'
3. Exit IM and Login again
4. All groups will be removed and you will have the default settings for IM
5. This will need to be done on every system running IM that you want to clear the Groups.

Additional Information:

This is an older doc link but helpful:

http://docs.nimsoft.com/prodhelp/en_US/Monitor/6.5/InfrastructureManager/index.htm?toc.htm?1986665.html?zoom_highlight=group+node