Incorrect CA PPM Application URL Is Reflecting In The Jaspersoft Report Email Notification For Scheduled Jaspersoft Reports

Document ID : KB000006620
Last Modified Date : 14/02/2018
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Issue:

When a report is scheduled from Advanced Reporting, once the email report notification is received, the embedded CA PPM Application URL is incorrect

wrong_url.JPG

Environment:
CA PPM 14.2 and ongoing versions
Cause:

The embedded CA PPM application URL on the report email notification, is derived from value set in the field Entry URL, available under the Application tab, present on the CSA.

In the following example, since HTTP is being used, the field to be referred to: "HTTP Entry URL"

 

Hence, this same URL will reflect in the embedded link, present in the report email notification

NSA_Incorrect.JPG

 

Resolution:

In order to get the correct embedded URL in the report email notification, the same must be set in the "HTTP Entry URL" field, available under the application tab, in the CSA. This is as described in the following points

 

  • On the CSA, under the application tab, set the "HTTP Entry URL" field, to correctly reflect the CA PPM Application URL

Capture.JPG

  • Once the above step is carried out, run the following Jaspersoft command from the application server: admin update jasperParameters . This command updates jasperadmin user's profile attribute using properties.xml entries and is run when PPM configurations are updated. For more details, related to the Jaspersoft commands, please refer to the following knowledge base article: TEC1027861
  • Restart all services of CA PPM by running the following command: Service Stop Start All

 

Post above steps, when a report is scheduled and subsequently the email report notification is received, it will have the correct CA PPM Application URL embedded in it

Correct_URL.JPG