Inbound notification filters are missing

Document ID : KB000128420
Last Modified Date : 28/02/2019
Show Technical Document Details
Issue:
We have previously configured which Inbound Notifications we would like to limit that comes back into IM from the Provisioning Server.  For example, the only two that we wish to receive are Modify Account Password and Modify User Password. For some time those were the only notifications we were seeing, but now there are other coming in. When I went back to look in the User Console at the Configure Inbound Notifications task and do not see any filters enabled.

We tried adding the filters back, but still do not see them "applied" through the UI.  The Enable Filter box is empty.

However I  look in the Provisioning Directory at the eTConfigPayload for BLS Connectivity Configuration and am seeing the following:
https://im.mycorp.com/iam/im/ETACALLBACK/?env=idv2Nohttps://im.mycorp.com/iam/im/ETACALLBACK/?env=idvModify_Account_PasswordModify_Global_User_Password.

I am assuming the filters we applied are the values listed above. But when we added additional values to the Enable Filter, we are not seeing eTConfigPayload get updated with the additional values. Modify Account Password - Modify_Account_Password Modify User Password - Modify_Global_User_Password. 

 
Cause:
The eTConfigPayload value in the Provisioning Directory repository may have become corrupted and needs to be cleared and reset.
Resolution:
You can check the stored values for the filters as described below and clear and recreate the value.  It may look okay but could be corrupted.

Connect via jxplorer to Provisioning Directory (the data repository on port 20391)

eTDSAContainerName=DSAs,eTNamespaceName=CommonObjects,dc=etadb

etadb > im > CommonObjects> > Configuration > BLS Connecttivity Configuration attribute is "eTConfigPayload"

Verify the value of eTConfigPayload.

If needed, copy value to notepad, clear attribute value, submit/save, reenter saved value from notepad and submit.