In the New UX, Unable to add Custom Attributes to Blueprints

Document ID : KB000092718
Last Modified Date : 21/04/2018
Show Technical Document Details
Issue:
In order to be able to add an attribute to a custom blueprint in the New User Experience (UX), the attribute must have an API Attribute ID. However, in  CA PPM 15.3, you are unable to add an API Attribute ID for a custom attribute on the Investment object so any custom attributes created on the investment object are unable to be added to Blueprints.

Steps to Reproduce:
1. In PPM, log in to the Classic UI
2. Go to ->Administration->Studio->Objects->Investments>Attributes
2. Click 'New' to create a new attribute

Expected Results: API Attribute ID field is visible so you can enter an API Attribute ID
Actual Results: API Attribute ID field is not visible

Note: If you enter required information and click Save you will also see that since there is no API Attribute ID, you cannot see the attribute in the Fields section of Blueprints in the New UX. 
 
Environment:
CA PPM 15.3
Cause:
This is caused by DE36486
Resolution:
This issue is fixed as of CA PPM 15.3 patch 1 and CA PPM 15.4 where the API Attribute ID is correctly visible to be added on the Investment object. Once a value is entered for the API Attribute ID for the custom attributes, you are able to add it to custom blueprints in the new UX.

Workaround: 
  • Create attributes in the Project object where you are able to enter the API Attribute ID (though this prevents the attribute from being available for NPIOs (Non-Project Investment Objects)
Additional Information:
For detailed information on getting started with Blueprints, reference New User Experience: Configure Project Blueprints   
Reference KB000073215 - In the New UX, Some Attributes Cannot Be Added To Projects for limitations on attributes that cannot be added to Blueprints
Reference KB000092719 - How can I add a Custom Attribute to a Blueprint in the New UX?