In the New User Experience, Unable to view a Status Report in Preview or Report mode if there are bullets in any of the text fields.

Document ID : KB000007129
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

In the New User Experience, unable to view a Status Report in Preview or Report mode if there are bullets in any of the text fields.

Two errors are generated in the UI: First error: “Could not preview status report”, then second error: “Could not parse json data to Map” 

Steps to Reproduce:
1. Create a new project in PPM

  • In the New User Experience (UX), click on the Projects icon on the left-hand menu then click the ‘+ Project’ button 
  • Click on any template to create the project from, enter a project name, and click ‘Create Project’ 

2. Click on the ‘Status’ tab 

3. Click ‘Edit‘ next to ‘Status Update’ (or any other editable text field) 

4. Open a new Microsoft Word document to create a bullet to paste into PPM: 

  • Click the bullet icon in Microsoft Word then type any word or phrase next to the bullet 

5. Copy the word and bullet from Word and paste into the ‘Status Update’ field in PPM 

6. Click on the ‘Reports’ tab 

Expected Results: Status Report is generated in a Report format 
Actual Results: No report is generated and receive the following errors: First error generated: “Could not preview status report”, then the second error generated: “Could not parse json data to Map” 

Environment:
This issue applies to CA PPM 15.1 and 15.2 in thew New User Experience
Cause:

This is caused by DE35223 

Resolution:

This issue is fixed in CA PPM 15.3.

Workaround:

  • Remove bullets from any text fields in the Status Report.