In the MSP New Driver, Tasks/Milestones added to Timeline view are not Preserved

Document ID : KB000006641
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

In the Microsoft Project (MSP) New Driver, any tasks/milestones added to the Timeline view are not preserved after saving the project to PPM and reopening the project from PPM to MSP.

Steps to Reproduce:

1. Create a project in PPM with one task

2. Export the project to MSP

3. Go to the View tab, then click the check box next to 'Timeline'

4. Double click in the Timeline section

5. Select the check box next to the task you just created and click 'OK'

(Observe that the task is now visible in the MSP timeline)

6. Save the project back to PPM

7. Export the project from PPM to MSP

8. Go back to the View tab, then click the check box next to 'Timeline'

Expected Results: The task you added to the Timeline in Step 5 is still visible in the Timeline section

Actual Results: The task is no longer visible in the Timeline section

Environment:
This issue applies to the MSP New Driver
Cause:

This issue is caused by a Microsoft Project limitation

Resolution:

This issue is due to a Microsoft Project limitation with XML. This is verified by testing with Microsoft Project Standalone using the following steps:

1. Create a new project in MSP with one task

2. Go to the View tab, then click the check box next to 'Timeline'

3. Double click in the Timeline section

4. Select the check box next to the task you just created and click 'OK'

(Observe that the task is now visible in the MSP timeline)

5. Save the project as a XML file using File->Save As in MSP ('Save as type' should be XML)

6. Open the XML created in step 5 in MSP

7. Go back to the View tab, then click the check box next to 'Timeline'

Expected Results: The task you added to the Timeline in Step 4 is still visible in the Timeline section

Actual Results: The task is no longer visible in the Timeline section

Additional Information:

- Click here to view other differences between the MSP Legacy and MSP New driver from the PPM Project Management User Guide

- Reference TEC1606998 : In the MSP New driver, highlighting of tasks is no longer saved

- Reference TEC1784816 : Can Custom Field Names in MSP be exported as column names for projects exported from PPM?

- Reference TEC1545414 : In the new MSP Driver, custom views are not Saved