In Service Desk Manager the bopauth_nxd.exe process keeps crashing at startup.

Document ID : KB000007331
Last Modified Date : 14/02/2018
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Issue:

The bopauth_nxd daemon will not successfully start up. If an attempt is made to manually restart the daemon with a pdm_d_refresh it will instantly start and stop 10 times and stop attempting to start up. A message in the log may appear that is similar to:

HOSTNAME pdm_d_mgr            2540 ERROR        daemon_obj.c          1990 Daemon bopauth_nxd died: restarting

HOSTNAME pdm_d_mgr            2540 SIGNIFICANT  mgr_slump_if.c        1221 Starting: $NX_ROOT/bin/bopauth_nxd

HOSTNAME proctor_HOST     840 SIGNIFICANT  pdm_process.c          572 Process Started (6348):C:/PROGRA~1/CA/SERVIC~1/bin/bopauth_nxd

HOSTNAME proctor_HOST     840 SIGNIFICANT  pdm_process.c          923 Process stopped (C:/PROGRA~1/CA/SERVIC~1/bin/bopauth_nxd return: -1073741790 

HOSTNAME proctor_HOST     840 SIGNIFICANT  pdm_process.c          932 Stopped: C:/PROGRA~1/CA/SERVIC~1/bin/bopauth_nxd

 

Environment:
Service Desk Manager 12.9 and newer versions
Cause:

The bopauth_nxd process has a reliance on the file bin\pcre-8.10.dll. There have been instances where an antivirus application installed on the server could block this dll file from being able to perform its function. If this occurs the bopauth_nxd daemon will be unable to start.

Resolution:

An exception needs to be added to the antivirus application that will allow this file to trigger. Please review this article for details on the recommendations that we provide for the configuration of an antivirus application on a Service Desk Manager server:

 

https://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC581795.html