In MSP New Driver, Baseline Duration and Duration Variance are incorrect

Document ID : KB000007084
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

In MSP New Driver, Baseline Duration and Duration Variance are incorrect


STEPS TO REPRODUCE 

1. In MSP, create a new task with a 4 day duration

2. Go to the Project tab, then from the 'Set Baseline' drop down select 'Set Baseline' and click 'OK' to create a baseline 

3. Add the 'Baseline Duration' and the 'Duration Variance' columns to a Task view in MSP

4. Observe the Baseline Duration correctly matches the duration of the task (4 days), and Duration Variance equals 0 (Duration - Baseline Duration) 

5. Save the project back to PPM

6. Go to the Tasks tab and add Baseline Duration to the task list view and view the value there. The Baseline Duration has now changed to 0

7. Export the project back from PPM to MSP and view the Baseline Duration and Duration Variance

Expected Results: Baseline Duration equals 4 days and Duration Variance equals 0 days has viewed in step 4 above

Actual Results: Baseline Duration changes to 0 days. Additionally, because Duration Variance is a calculation of Duration - Baseline Duration, this is changed to 4 days because the Baseline Duration is now 0

Environment:
This applies to CA PPM 14.4, 15.1 and 15.2
Cause:

This is caused by DE33204 

Resolution:

This issue is fixed in CA PPM 15.3.

Workaround: 

  1. In Microsoft Project under the “Project” tab select “Custom Fields”

  2. Select the “Task” radio button with Type “Duration”

  3. Select the field you would like to customize in the “Field” text box

  4. Under “Custom attributes” click on the “Formula” button

  5. Input the following formula "ProjDateDiff([Baseline Start],[Baseline Finish])".

  6. Create the custom field by clicking the “OK” button from all windows

  7. Add the Custom Field to the Global.mpt:

  • Click on the “File” tab and click on the “Organizer” button

  • In the Organizer window click on the “Fields” tab. Click on the Custom Field created in the project and copy it over to the “Global.mpt”