In CA Spectrum exporting Alarm Filters to groups doesn't change the filter for users in that group

Document ID : KB000004101
Last Modified Date : 14/02/2018
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Issue:

In OneClick when groups or users have the same Alarm Filter name as the Alarm Filter being exported, the updated Alarm Filter does not overwrite the older filter.

1)  In the Users tab, select a single user that has an Alarm Filter that needs to be applied to other groups.

2)  Select -> View -> Preferences

3)  Select "Alarm Filter" and click the Export button

4)  Select the Alarm Filter(s) you want exported and click Ok.

5)  Select the groups/user to apply the export to.

6)  Notice the updated filter is not applied.

Once this is done the exported filter shows under Alarm Filters but the changes to the filter are not reflected if that user/group already had a filter with that same name

Cause:

This was originally functioning as designed:

Filters with the same name do not get updated with an export of a filter with the same name. This is to make sure users custom filters are not overridden. The way around this is to have a new filter name that can be pushed to the groups/users.

This functionality has been changed.

Resolution:

The functionality is tentatively scheduled to be changed with CA Spectrum release 10.2.2 and above.  For CA Spectrum 10.2.1 a program temporary fix (PTF) has been created:

 Spectrum_10.02.01.PTF_10.2.152

The change will allow alarm filters that are exported to other user/groups to allow the update/change to be applied without having to create a new alarm filter with a different name. 

If you need a copy of the  Spectrum_10.02.01.PTF_10.2.152 patch please open a case with CA Support.  

 

Additional Information:

CA Spectrum 10.2.2 and 10.3 are tentatively scheduled to be released in the last half of 2017.